Results 1 to 3 of 3

Thread: Audio Stutter and Video Lag - Version 0.53.1938.4

  1. #1
    Beta Player Recruit
    Join Date
    Jul 2017
    Posts
    2
    Level
    2
    Points: 114, Level: 2
    Level completed: 28%, Points required for next Level: 36
    Achievements:
    Tagger Second Class 100 Experience Points

    Question Audio Stutter and Video Lag - Version 0.53.1938.4

    I've been playing Paladins for a while now (I've gotten up to player level 13) and just yesterday, when I played my first siege game, I noticed that the game started lagging a lot as well as accompanying sound stutter that was deafening.

    Be warned that I do play this game on a laptop but I updated all drivers and my BIOS and still nothing's solved. I also looked online and found solutions where I had to change my power settings to high performance and change audio bit depth and such which still didn't solve anything. I also switched to integrated graphics and lowered my settings and i still had the same issue.

    Furthermore, I'm not experiencing any such issues with games like Tekken 7 and Dirt 4.

    I've got a Dell XPS 15 9560 core i5 and a GTX 1050.

    I'm also running the latest patch of Paladins.

  2. #2
    Beta Player Recruit
    Join Date
    Jul 2017
    Posts
    1
    Level
    2
    Points: 102, Level: 2
    Level completed: 4%, Points required for next Level: 48
    Achievements:
    100 Experience Points
    Same here, this happened just yesterday to me after downloading an app. I couldn't play well because of this. I'm playing Paladins on PC. I hope this will be fixed for some people who have this kind of problem. T_T

  3. #3
    Beta Player Recruit
    Join Date
    Jul 2017
    Posts
    2
    Level
    2
    Points: 114, Level: 2
    Level completed: 28%, Points required for next Level: 36
    Achievements:
    Tagger Second Class 100 Experience Points
    So, I tried playing paladins today but before I did, I had opened the launcher but hadn't clicked play yet and I had the Steam dialogue box open cause I was browsing some games. And for a while it was perfectly fine.
    Unfortunately, after about two games the stutter came back.

    I'm gunna try defragmenting my drive and then try it again to see if that helps.

    If not, just going to wait for the new patch in hopes that they've fixed it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •