PDA

View Full Version : Mouse Issues In Game



Swiftburn
06-08-2018, 09:21 AM
I used to play paladins a lot, stopped playing and now coming back because of the Switch announcement. I say that for two reasons. First, I am not new and have run into various mouse issues with the game. Second, Hi-Rez has to be careful to make sure there arent any bugs or issues with the game at this critical juncture. A lot of potential Switch buyers are going to play the free PC version to see if they want to get the game.

The Issue
My mouse works in menus but not in game. I can click, but cannot look around. I have seen this issue before when controller like peripherals are plugged in. Before it was an issue with the Steam controller, it couldnt be connected, then the orbweaver, similiar. This time I uninstalled any controllers, unplugged my Tartartus and still no joy. I cannot use my mouse in game except to left and right click. It is possible it could be due to my firefly mousepad or some other potential conflict. At this juncture I don't want to start unplugging everything systematically to test this. This issue should have already been addressed and resolved, no other FPS has an issue on my rig except Paladins and it has been an issue for awhile. I see in the options a new option was added, "Allow Controller". That appears to be the easy fix to the issue but it isnt fixing my issue.

For me it isnt a huge issue, I will pickup the Switch version because that is what drew me back. I am concerned about others that will try the game, hit these bugs and decide not to purchase.

Swiftburn
06-08-2018, 03:23 PM
Ok fixed it, the only reason I took the time is because I want to try Terminus, he looks awesome.

I set the Paladins exe to run as admin and set to Windows 8 compatability mode. I think the Windows 8 compatability mode is what worked, however if you (the devs) are doing some anti-cheat stuff with mouse controls and trying to access windows sub systems running the exe as admin might have helped.

Anywho for those with the issue do this:

1) ...Hi-Rez Studios\HiRezGames\paladins\Binaries\Win64 (or Win32 if you are running a 32 OS)
2) Right click the paladins exe
3) Go to the compatability tab, select run as admin and set compatability to Windows 8.

Now I also did the same thing for the Hirez Launcher and then also launched the game by right clicking the icon and doing run as admin. However i think the setting to Windows 8 compatability fixed it.