PDA

View Full Version : Can't run the game (bought on 3th of april)



MiniPanda
09-26-2016, 04:20 AM
So I want to play this game again, since it does seem alot of fun again!
When I tried to open up the client I still had installed, it gave me an error:
'Cannot start Hirez Authenticate and Update Service'.
Running as admin doesn't work.

Then I tought maybe the client is outdated, so I tried to download a new one from the website,
only www.paladins.com is down for some reason and I can't get on the site..

Anyone got any tips? I don't want to play via steam as I've already played alot on this account.

Edit:
Okay via Edge I could reach the Paladins site. I've deleted my old Paladins, and downloaded the client. Now when I tried to install the game, it says that Paladins is already installed... Dafuq?

Edit2:
After several tries it works. Now it says (when it's busy installing):
'Failed to start the Hi-Rez Studios Authenticate and Update Service'.
This is actually taking way too much effort to install..

WipeoutPT
09-26-2016, 06:07 AM
Unistall that one and try to install via steam. Also try to disable your antivirus when i stalling/playing